Subscribe2 HTML v12.5

Version 12.5 of the Subscribe2 HTML has been released and is available now. This version has been tested on WordPress 5.5.x and 5.6 and ClassicPress 1.2.0. It requires at least WordPress 4.4.

Current users of Subscribe2 HTML with an active support and upgrade subscription via Freemius can upgrade via the Plugins page within their blog dashboard.

This version is being sold through Freemius. Current users of Subscribe2 HTML with a subscription from Semper Plugins can upgrade using the discount code already provided via email or can contact Semper Plugins for upgrade details.

Version 12.5 contains the following enhancements and bug fixes:

  • Update Widget names for Subscribe2 HMTL
  • Bug fix to enable Subscribe2 HTML Widget to display in new Widget Block Editor
  • Move translation template file to /languages sub-folder
  • Simplify translation code to locate mo files in /languages folder, admin translation supported from WordPress 4.7
  • Fixed duplicated responses in Pop Up (Ajax) subscriber form
  • ESLint tidy in some JavaScript files
  • Update to latest release of the Freemius SDK
  • Tested on WordPress 5.5.x, 5.6 Release Candidates and ClassicPress 1.2.0
  • WordPress 5.6 ready