Subscribe2 HTML v12.4

Version 12.4 of the Subscribe2 HTML has been released and is available now. This version has been tested on WordPress 5.5 and 5.5.1 and ClassicPress 1.1.4. It requires at least WordPress 4.4.

Current users of Subscribe2 HTML with an active support and upgrade subscription via Freemius can upgrade via the Plugins page within their blog dashboard.

This version is being sold through Freemius. Current users of Subscribe2 HTML with a subscription from Semper Plugins can upgrade using the discount code already provided via email or can contact Semper Plugins for upgrade details.

Version 12.4 contains the following enhancements and bug fixes:

  • Update jQuery UI CSS library for pop up form to latest version
  • Ensure compatibility with planned jQuery updates starting in WordPress 5.5 and through to WordPress 5.7
  • Ensure admin emails are sent for new subscribers from comment forms
  • Update to latest release of the Freemius SDK
  • Efficiency enhancements to code handling subscriptions made via comment form
  • Improved Block Editor detection to fix console errors with WooCommerce
  • Improved compatibility with Classic Editor plugin
  • Enhanced Block Editor suppression detection via other plugins
  • Move admin meta code for Classic Editor to new class to reduce code loading overhead
  • Reduced legacy code overhead for Block Editor users
  • Updated JavaScript compression during build process